Page Contents

必要なもの

  • HTTPサーバ。例えばApacheなど。mod_rewriteが使えるのがお勧めですが、必須条件ではありません。
  • PHP 4.3.2以降。CakePHPはPHP4とPHP5の両方で動作します。

厳密に言えば、データベースエンジンは必須ではありません。でも、大部分のアプリケーションではデータベースを利用しています。CakePHPは、様々なデータベースのストレージエンジンに対応しています。

  • MySQL (4以降)
  • PostgreSQL
  • Microsoft SQL Server
  • Oracle
  • SQLite